News Office Field Order Support Contact Us

January 16, 2014 10:23PM
I apologize for the delayed response. It appears that we missed this post.

W-M Topo requires the Nomad or Yuma 2 (T71) packages. It will not work with the T-41.

Thank you for the inquiry.

Deb Hurraw
SubjectAuthorPosted

Juno T-41

OSU-FSRJanuary 10, 2014 03:52PM

Re: Juno T-41

Deb HurrawJanuary 16, 2014 10:23PM

Re: Juno T-41

OSU-FSRJanuary 23, 2014 02:45PM



Sorry, only registered users may post in this forum.

Click here to login

Privacy Statement | Terms of Use | Copyright 2009, Trimble Navigation Limited